Client Freezes

For the past 4 days now as of writing this, I have been having an issue where I cannot play league of legends due to what appears to me to be a bug that results from the most recent patch. (or at least that is my theory for what started to cause it) Issue: Every time I open up league of legends and queue up for a match the client freezes up and nothing is clickable. The queue timer fails to appear and same with the pop up Accept or Decline buttons. When tabbed out of the client I still get the orange flashing to show me when the accept/decline button appears so to my knowledge I am still being put into a queue but I cannot view the timer or accept/decline the match. I have restarted league of legends multiple times and have also ended all league of legends process before restarting. I have also restarted my computer a dozen times to no avail. I have had the client installed since the closed alpha and I have not had any issues similar to this one since. I have not messed with any files in the league of legends folder. I don't think I have even opened that folder in the past few years and I have never messed with anything inside the folder. I could not find anything similar to my issue online which is why I create this discussion in Ask the Community for help. Edit: just ending the application using task manager ( I cannot close the application by using the 'x' buttons on either the client or taskbar) restarts the client to an endless loading screen with the LoL icon in the center and a loading bar that never finishes. Edit 2: when closing all processes including the 'LeagueClientUxRender.exe *32' that is created every time the client is opened, I am greeted by the login screen, which works perfectly fine, then the same loading screen as described in edit 1 appears but this time it finishes. After it finishes it still has me in a party with the same gamemode selected and roles selected as before I closed the application and processes in taskmanager. When clicking the 'x' button to leave the party I am greeted by the frozen client once again. Edit 3: After logging back in after that, I still appear in the party. Every button is clickable from the home screen and working fine (shop, inventory, cards, etc.) I can view the party and change the roles but if I hit the x button once again then I am taken back to the home screen but it is frozen once again. Edit 4: After logging into my second account that I don't play on often, the same issue appears when I queue up for a match ( I did draft pick but I don't think the gamemode type matters) except this time the queue timer appears but is frozen at 0:00. I am just going to wait for the next patch and hopefully whatever is happening is fixed by then. Edit 5: I went to the settings after remembering there is a way to repair the client if it is broken at all. I will update after on whether it does or does not fix my issue Edit 6: unfortunately, repairing the client did not solve my issue. I am bummed out because I honestly thought it would. I might consider reinstalling the whole client using the installer from the website. Edit 7: Hopefully this is my final edit. My game has finally started to function properly once again. I do not know if this is related to my computer being restarted since I tried to repair the client or something else but I can finally queue up for games and the timer appears and works. I am going to leave this thread up for anyone who is facing the same or similar issues and maybe this will help them in some shape or form.
Report as:
Offensive Spam Harassment Incorrect Board