Custom Hotkey Bindings Broken With Recent Patches

Recent patches have broken custom hotkey combos where more than one key is bound to an action. This used to be possible with custom hotkeys edits in the input.ini file by using [button1][button2] to create the two button hotkey (it is the same as, for example, [alt][q], [shift][q], etc for spells, which can be set easily as normal hotkey bindings without having to edit input.ini). In recent patches these hotkey bindings changed so that first they began to not only do the hot key binding but also do individual key press at the same time, so FOR EXAMPLE if your bind was [button 3][q] to level up a spell (which previously worked fine) then now when you press mouse button 3 and q it would not only level up your spell but also CAST the spell. In the latest hotfix patch, whatever it did, it CHANGED AGAIN AND WORSE so that now the same binding [button 3][q] causes you to level up (when available) and cast the spell every time you press q. This is very problematic when doing spell combos and such, as you end up with spells leveled up without even realizing it happened. **In other words, the ability to create combo bindings has been broken.** I realize this might not matter for most players, but for those of us who use highly custom keybindings it is a huge deal. **If we create combo hotkeys like [button 3][q] it should function in the same way as the [alt][q], [shift][q], and [ctrl][q] which are able to be bound in game without having to edit the input.ini ** Again this worked fine until patches in the past week or so. PLEASE FIX THIS SO IT WORKS AGAIN! THANK YOU!!!
Share
Report as:
Offensive Spam Harassment Incorrect Board
Cancel