Hextech repair doesn't even work and i'm still not loading in :)

Feel free to look at my past boards about this because i post one almost ever other day saying the same thing. basically whenever i go to play RANKED i load in 100% in the loading screen but about half the time i never actually load in. instead i get booted out at 100% and by the time i get that message the game has already been remade. then i go to play 5 games of nexus blizt with 20 minutes low priority ques and load into those games or arams PERFECTLY FINE. but then when i go back to ranked i'm booted out. it's so fucking annoying because i don't care about other game modes besides ranked. i've tried using the hextech repair tool and when ever i do it never finishes. unless i'm using it wrong. it's not very clear how it even works. unless i'm supposed to leave it up while i'm loading/ playing games let me know. because whenever i open it, it just sits there loading and never finishes loading. any help would be appreciated instead of the usual no help ignored post where i get no solution to my problems.
Share

Seems like no one has joined the conversation yet, be the first to comment below!

Report as:
Offensive Spam Harassment Incorrect Board
Cancel