Unable to start games OR submit a support ticket

FIrstly, my main problem is that every time I try to start a game on summoners rift the actual in game window never opens and crashes before I even see the loading screen. It works for bot games, but it only does this when playing real people. Because of this I'm loathe to try again because in doing so I automatically afk a game with real people and get myself reported, and waste other people's time. I've tried reinstalling and using the hextech repair tool and it hasn't helped, but I do have the logs. Secondly I tried to submit a ticked for this, but even though on the website it clearly showed me as logged in in the corner of the screen, when I selected "I am having technical issues", red writing saying "You must be logged in before you can submit this type of ticket." appears. When I click the login link under this, I go to another screen saying "An unknown error has occurred. Please wait a minute or so before trying again.". I'm in a situation where I can't play for some reason, and I also can't even get any help.
Share
Report as:
Offensive Spam Harassment Incorrect Board
Cancel