Not Being Able to Edit Posts on Boards

I'm at a complete loss here and kinda at my limit at this point. I've been trying to make some edits to this post of mine that a posted roughly a week ago now. However when I try to do so a small white box pops up whenever I hit save and says > says: Couldn't update the content! I've tried almost every method I can think of to clear this up: clearing my browser cache, login out and back into my board account, waiting to see if this was just a time based thing. Hell I've even tried restarting my computer to see if that worked, as well as switching over to my laptop to make the changes thinking it was my main computer but the same thing still happens. So now I'm convinced that it has something to do with my account but I don't know what it is. And honestly I'm completely dumbfounded because this wasn't happening a week ago and it's already been a few days since this began. I really want to know how to fix this!
Report as:
Offensive Spam Harassment Incorrect Board